Note: Failed delivery logs are only available to customers subscribed to an ExpressVPN Advanced or Express Pro plan.
The Failed Deliveries section of the ExpressMailGuard dashboard provides you a granular view of bounced or failed emails to help you diagnose missing messages.
It only includes failures where ExpressMailGuard tried to send from our servers to your recipients, including send or reply attempts from your aliases. It does not include messages that failed before reaching ExpressMailGuard from another sender.
Jump to…
How to enable Failed Deliveries storage
To view any failed delivery attempts, ExpressMailGuard has to store the content of the email. This ensures that emails are not lost if they are rejected by your recipients, as they can be downloaded from the failed deliveries page. Failed deliveries are automatically deleted after 7 days.
You can choose to enable or disable ExpressMailGuard from storing your failed deliveries at any time. To do so:
- On the ExpressMailGuard dashboard, click Settings.

- Click the PRIVACY & STORAGE tab.

- Under Store Failed Deliveries, click the dropdown menu and select your preference.

- Click Update Store Failed Deliveries.

How to view and download Failed Deliveries
If you have enabled ExpressMailGuard to store your failed deliveries, you can view and download these failed deliveries.
To view your failed deliveries: Click Failed Deliveries from the tabs on the left menu in the ExpressMailGuard dashboard, and you will see a list of all the failed deliveries from the last 7 days.![]()
To download your failed deliveries: Use the horizontal scrollbar to scroll all the way to the right, then click Download next to the failed delivery you want to download.![]()
Need help? Contact the ExpressVPN Support Team for immediate assistance.